Using WP User Avatar Pro version 4.1.2 and WordPress 4.9.2 on a large, high-traffic site. They reported that the media library was loading slowly, and when I went to investigate I actually wasn’t even able to get the media library screen to load content (it would load the sidebar, but no admin bar or library table).

This was occurring on their production site, staging site, and the local version on my machine, across all major browsers. It also occurred when it was the only active plugin, using a default theme. Deactivating WP User Avatar Pro immediately solved the problem.

Occasionally I would see an “allowed memory size exhausted in ” error, though the file noted would be different each time I reloaded or the error wouldn’t even show up. Looks like something is causing a loop, maybe? Hopefully, that helps.

I wasn’t able to discern what is the plugin is causing the issue. However, we just bought this license in October and I’m hoping you’ll be able to replicate and solve the issue.

Appreciate the help!


We are sorry for your all inconvenience you had, please provide us your wp-admin details so we can inspect it at your end also.

Hello Joshua,
This is a server side issue, you have to make changes in your .htaccess file.
Please insert this code on your .htaccess file

php_value post_max_size 2000M
php_value upload_max_filesize 2500M
php_value max_execution_time 6000000
php_value max_input_time 6000000
php_value memory_limit 2500M

Please try this and your issue will be resolved.

Note: Please make a backup copy of your current .htaccess file for security.

Please login or Register to Submit Answer