Steps to reproduce :
Set the Avatar Upload Size Limit to 2mb.
Try to upload a 2.5MB mp4 file as a non admin user.

Output:
Upload error.

Quick fix:
Disable WP User Avatar plugin.

Long term fix:
Please modify your codebase to use Upload Size Limit only to files with images extension submitted by Avatar HTML Form.

Public
Hello,
Mp4 file is not supported by this plugin. This plugin supports only image file like jpeg/png/gif. You can change the upload file size from avatar settings.
I have enclosed screenshot.

Thanks
#1
Public
I might not have described the issue clearly but your feedback is irrelevant. Nobody tallks about avatar image uploading, what I am trying to bring up is that your plugin is disturbing upload limits at cross system level to all non admin user and all files.

Let’s start again:
The problem here is that your avatar restriction has impact on user upload limit which are not even related to avatar image upload. It means that user with a status vendor is limited with avatar settings even if he tries to attach a file to a normal product in woocommerce.

Steps to reproduce:
Go to /wp-admin/admin.php?page=wp-user-avatar
Set the upload limit to 1mb .
Login as a non admin user, in our case we deal with a woocommerce vendor, create a product and try to upload a digital file for bigger thant 1 mb.
You will get upload size limit error even though the your system may be set for much bigger upload limits.

The issue goes away as soon as we either disable the avatar plugin or modify the avatar upload limit.
We are clearly dealing with avatar plugin issue here.

In our case we have a markeplace wp instance where users with a status of vendor can create products and attach digital files for selling. Your avatar plugin is limitting them to upload their digital products. I would like to underline that we are not talking about avatar image uploading but about digital products which are being attached to a product page.
#2

Please login or Register to Submit Answer