I just submitted a contact form with this, but I thought I would send here as well. I just launched a site that is using Google Maps Pro plugin. During the buildout, the plugin was working fine. The buildout is on WP Engine. As soon as I launched it yesterday, the maps have broken and are showing errors. This is what I am seeing when I inspect in Chrome.
“You have included the Google Maps API multiple times on this page. This may cause unexpected errors.” I don’t understand where the multiple times is coming from. Site is tourcartercounty.com and maps are on tourcartercounty.com/stay and tourcartercounty.com/explore.
This is pretty important because I just launched their site yesterday, and these maps are a pretty important part of their site.
Thanks.

Public
Hello,
You are getting this message because you are using multiple google maps plugin or your default Wordpress theme comes with a Google Maps Functionality, so both API's are conflicting and creating an issue.

If you are using any other maps, other to this plugin please remove them or need to disable to theme google maps API key to resolve this issue.
Please try this and let me know.
Thanks
#1
Public
Thanks. You were able to take care of the issue if the maps not displaying. However, there is now a new issue that has just arisen. I don't know if it has anything to do with the recent adjustment, but the issue just appeared. On the 2 map pages, the category marker icons are displaying as huge and therefore blurred out. For some reason, the css is forcing them to display at 200px wide, but I don't know why. Throughout the buildout, the icons displayed perfectly. You still have the login for the admin for the site. Can you please take a look and see why all of the sudden this is happening. It is on the 2 map pages that you fixed.
#2
Public
Hello,
Please check it now, we have resolved this issue.
Thanks
#3
Public
Thanks, that worked. Hopefully, one final question. I am placing images on some if not all of the map locations in the listings. I have added a field called location-picture, and I am wanting to use it to insert an image of the location in the listing. It appears that the image is being controlled by the same code that is controlling the category icons because they look to be the same size. An example of what I am trying to do can be seen on the EXPLORE page under a listing called Carver's Gap. I would love to be able to insert these images into the listings. Thanks.
#4
Public
Hello,
Sorry for delay, we have set up a new static width of 200px in your listing {location-picture} placeholder settings. Now you don't need to insert full path of the image with an img tag in manage locations. You just need to insert the proper path of the image in the location picture extra field and save it.

Your location picture will be seen on the listings front end without any issue. I have inserted one image in your "Coon Den Falls" for proper testing.
Please check your link https://tourcartercounty.com/explore/
I hope your issue has been resolved.
Thanks
#5
Public
I have another question. On the STAY page, I originally had the locations listed in grid view instead of list view. When I first created the map, all of the locations were consistent in size so they all looked the same size. Now if I choose grid view, each location varies in size, so it doesn't look as good. Also, on mobile devices, the grid view doesn't look good at all, and the content overflows the container size. I switched the view on the map for STAY to list for now because it looks better, but ideally I would like to have grid view working on this page, if I could go back to how it was when I originally created the map. Can you take a look and let me know what is going on?
#6
Public
Hello,
Please check it now we have resolved your issue. Now your listings grid are displaying very well in mobile/smartphone devices and responsive also. This is your link https://tourcartercounty.com/explore/
Thanks
#7

Please login or Register to Submit Answer