This is weird. For some users, the uploaded WP User Avatar is working, for others, not. It seems that if the user had a Gravatar already, the plugin is not retrieving the WP User Avatar, but still using the Gravatar.

I tried disabling Gravatar in the settings, no change.

I’ve flushed all the caches and reloaded the page, but no change.

Also, I read somewhere that if you do not disable Gravatar in the settings, it will show the Gravatar if the user has one, instead of the WP User Avatar. I think this is backwards. We are using the plugin for a reason, after all. If there is a WP User Avatar, it should be used first, then the Gravatar if there is one. If this is the plugin behavior, users should be able to set it the other way.

Please help. Thank you.

Public
To update the question: when I disable Gravatar in the settings, no avatar shows for this particular user (admin, btw), even though the new avatar has been uploaded and shows in the user profile.
#1
Public
Hello,
Please send us your wp admin details at support@flippercode.com so we can check your backend settings and resolve it. When you disable the gravator than only default local avatar will be display and gravatar will be disabled.

Thanks
#2
Public
Yes, I realize that when you disable the gravatar, only default local avatar will be display and gravatar will be disabled. I would prefer to leave it enabled. But either way, the local avatar should take precedence, correct? Right now it's disabled, but as I said, the local one is not showing.

You can see it on this blog post: http://testsite.humortimes.com/58073/election-editorial-leaky-boat/ (scroll down to the author box).

I will send my login details, as you request. Thank you!
#3
Public
Hello,
Your local avatar (hat man) has been showing there in your author box,. If your email id has assigned on a gravatar than gravatar will display if you disable gravatar from backend then your local avatar will be display. I checked your backend and applied a local new avatar image at your end and it is displaying without an any issue.

Thanks
#4
Public
Well, that is strange, since I had already done that, and it was not displaying. In fact, I did it twice. However, my avatar is now displaying for EVERYONE who does not have a local avatar. That is totally unacceptable. How can I fix that?

Again, you guys should REALLY reconsider letting the gravatars display if there is no local avatar. It would be a much better system.
#5
Public
I checked, and you had set the 'default' avatar as my pic, that's why everyone's avatar was using it. Don't know why you did that. I set it back.

So, it's working fine now. Also, the way you say it, I misunderstood. But when I changed the settings back to enable gravatar, it is working the way I want, with the gravatar showing as the default if the user has no local avatar.

Thank you.
#6
Public
I hope your issue has been resolved. If users email id has registered in Gravatar.com then gravatar will display on profile page otherwise user need to select local avatar.

Thanks
#7
Public
Thanks, Divyang, but you need to know that in this thread, and on the Wordpress support page, the information I got was misleading, and sometimes wrong, which is why I was confused.

In this thread, you say, "If your email id has assigned on a gravatar than gravatar will display if you disable gravatar from backend then your local avatar will be display." That seems to imply that unless you disable gravatar, the local avatar will not show.

On the WP support page, the reply I got from @ruchisupport was, "If you are using Gravatar then your gravatar will display first, to display avatar you need to disable gravatar from plugin backend settings then your default local avatar will be display."

That is just plain wrong. In fact, as it should, your plugin displays the local avatar first, and if there is not one, the gravatar image will display.

I'm just trying to help you communicate to your users better, as I was quite confused by these responses from your company.

I do like the plugin very much, though. Thanks.
#8
Public
Hello,
Thanks for your valuable suggestions and we try to provide best support from our side. Gravatar is globally recognized avatar which is directly links with your mail id. If you assigned gravtar to your mail then where ever you used your mail at any forum or site gravatar is applied automatically as a avatar. If you want to use local avatar instead of gravatar then you need to disable Gravatar. So this is the main concept. You can mail me direct at support@flippercode.com for any information or issue.


Thanks
#9

This question is now closed