I am getting the below error trying to connect a google drive account to this plugin. I followed the video guide here:

Error:
—————–
400. That’s an error.
Error: redirect_uri_mismatch

Request Details
response_type=code
access_type=offline
client_id={CLIENT_ID}
redirect_uri=http://{WEBSITE}/wp-admin/admin.php?page=wpdf_gdrive_settings
state=
scope=https://www.googleapis.com/auth/drive
approval_prompt=force
That’s all we know.

Public
Sorry, I meant the following video:

https://www.youtube.com/watch?v=0kw3Ij80BGQ
#1
Public
Hello,
You are getting this error message because you have not inserted your site URL. For example, if your site URL is http://www.example.com then you have to insert URL in google console. I have enclosed screenshot. Please try this and your issue will be resolved.

Thanks
#2
Public
Unfortunately that is not the issue. I have the website url properly set on the OAuth consent screen, i double checked, and can confirm it is accurate. I even tried with and without a trailing /.
#3
Public
Hello,
That means you have inserted the wrong API and secret key and some space are added on a secret key during copy paste. I just check it at my end and set up a new google drive settings and the account is synced without any issue. You can send me a screenshot of your google console so I can also check it at your end.

Thanks
#4
Public
i have the same problem with google drive configuration.
#5
Public
Hello Faerias,

Please follow this guide tutorial https://www.youtube.com/watch?v=0kw3Ij80BGQ&list=PLlCp-8jiD3p1w9znvmRdh7Vkkmv-dtjn5&index=6 and your issue will be resolved.

Thanks
#6
Public
I did it step by step 4 times and continue with the same error
#7
Public
Hello,
Are you inserting correct URL of your site on google console? Please send me the screenshot, so I can check it.

Thanks
#8

Please login or Register to Submit Answer