Hello, I hope you can help.
Just installed your plugin and used [avatar] shortcode in the sidebar widget. For all users it only shows the wordpress site’s admin gravatar. If I change the shortcode to [avatar user=current], it shows the mystery man even though my user has a gravatar and that gravatar is showing in the wordpress toolbar.
Interestingly, if I change the default image, my wordpress toolbar stops showing my gravatar and shows the default image I chose. Even then the widget still shows the mystery man.

Do you know how to fix? I’m running a membership site so would like to show a default image of my choosing until they upload a gravatar but i can’t get it to show!

Public
Hello,
If you are using Gravatar then your gravatar will display first, to display avatar yo need to disable gravatar then your avatar will be seen. You dont need to pass "current parameter" defaulty your currrent set avatar will be seen.

Thanks
#1
Public
Thanks for the reply, though what I'm saying is I want to show the logged in user's gravatar, though when using the [avatar] shortcode, it only ever shows the wordpress admin's gravatar no matter who is logged in to the site. So say I log in as a subscriber to the site, I see "Welcome " and a picture of someone else (the admin).
You'll see in my screen shot in previous message that I just cannot get my gravatar image to show.
[avatar] shows admin's gravatar
[avatar user=current] shows mystery man

I want subscribers to the site to see their own image, not my admins. Am I doing something wrong?
#2
Public
I just check it at my end and there is no issue here, user selected avatar is displayed. Please send us your wp login details at support@flippercode.com so we can check it at your end and resolve your issue.

Thanks
#3

Please login or Register to Submit Answer